This project is read-only.

RC1.1 outstanding bug with jQuery 1.6.1

May 27, 2011 at 5:21 AM

I've noticed that I can only run the Data Grid on version 1.4.4 of jQuery.  If I run the version on 1.5.1 or 1.6.1 I get a JS error when I click on Add.

"Syntax Error, unrecognized expression"

It is thrown in the jQuery script and am not sure what is causing it.  I have downgraded jQuery to 1.4.4 in the meantime.

Cheers,

Craig

 

Coordinator
May 27, 2011 at 10:15 AM

Verify you have substituted all over your project the new MVCControlToolkit.Controls-1.1.0.min.js replacing the old MVCControlToolkit.Controls-1.0.0.min.js

Moreover verify also you have substituted the new jquery.validate-1.8.1.js with the old one because the old one is not compatible with the newer versions of jquery.

You can find the jquery.validate-1.8.1.js in one of my example projects.

Please use the new names of the js libraries and NOT RENAME THEM to avoit substituting their names all over your project because otherwise the browser will use the old cached caopy of the file instead of the new

...you can force a browser refresh...anyway if you have not already distributed your application

May 30, 2011 at 11:57 PM

Thanks Frank, forgot to switch to 1.1.0 of the toolkit.